Remote Controller and Drone

Discuss Firmware Updates
bman0145
Posts: 2
Joined: Thu Feb 18, 2016 5:35 pm

Remote Controller and Drone

Post by bman0145 » Wed Feb 24, 2016 12:40 am

Hello. I have a new Explorer V fresh out of the box. The remote controller and the drone will not recognize each other no matter how many times I attempt to "pair" them.

On the controller; the two outside led indicators - Left is for the extender/Right is for the controller power. When I power up the controller, both of these turn green.

The two L/R center led indicators - Left is "pair-to-drone" indicator/Right is GPS indicator. Both of these are consistently red with no change whatsoever no matter what I do.

When I power up the drone without turning on the controller, I initially get rear white lights and no front lights until 3 seconds into power up. At that point, I get 4 red corner lights with no other change. Normal power up with controller power up first and then drone gives me the outside green/inside red on the controller and all 4 corners red on the drone.

I have downloaded the proper upgrades several times from the http://www.xirodrone.com website indicating the following for my iOS software upgrade:

Flight Control Firmware - UA3500_FCU_FW_1.0.0_20150710.bin
Gimbal Firmware - UG3300+V_PTZ_FW_1.0.0_20150521
Camera Firmware - unzipped and copied the unzipped file UG3300EN.bin to the mini-SD card

I have followed the pairing routine religiously including placing the needle in the reset hole while powering on the drone after powering on the controller with sticks upper and lower corners.

NOTHING I have done allows pairing of the drone to the controller.

I'm sure I've completed the updates successfully. I haven't found any mention of upgrading the software for the controller and see no mention of it in any website or other area.

The only thing I can think is that the software in the controller is corrupt and needs to be reloaded. Is there someone who has that software file and would send it to me???

BTW - all batteries are charged and no damage has been sustained to the controller or drone. Like I said - new out of the box.

In addition to all of this, I have TRIED to calibrate the compass with no luck.

Thanks in advance for any help you might offer.

veldmpet
Posts: 1
Joined: Sun Apr 10, 2016 3:53 pm

Re: Remote Controller and Drone

Post by veldmpet » Sun Apr 10, 2016 3:56 pm

Hi, I have the same problem you describe. I am not able to pair the controller with the drone. Did you manage to find a solution for this problem?

reddog
Posts: 1
Joined: Mon May 09, 2016 3:09 pm

Re: Remote Controller and Drone

Post by reddog » Mon May 09, 2016 7:07 pm

My friend is also having this problem after the firmware update any solutions?

thespecialist
Posts: 1
Joined: Sat May 14, 2016 3:50 am

Re: Remote Controller and Drone

Post by thespecialist » Sat May 14, 2016 3:59 am

I am having the same problem. I have tried pairing the drone with the controller with no success. Initially the green aircraft indicator light comes on but goes back to red. Also my remote vibrates when the aircraft indicator light is red. Is there an amount of time you should hold down the pairing button when you turn on the drone.

Kamclaren
Posts: 1
Joined: Sat May 14, 2016 7:12 pm

Re: Remote Controller and Drone

Post by Kamclaren » Sat May 14, 2016 7:14 pm

Same exact issues here. Right out of the box. Any luck finding answers?

User avatar
m15alien
First Officer
Posts: 107
Joined: Mon Jan 04, 2016 9:08 pm
Contact:

Re: Remote Controller and Drone

Post by m15alien » Sun May 15, 2016 12:40 pm

Sorry, i cannot help, i only suggest to try to upgrade again the FC firmware a try the binding procedure, if it does not work that i would try to contact (just write) the Xiro support.

Bye
' /\.|_.|.[-.|\|.

Redmi Note 3 Pro - Android 6.0.1
_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
Xiro Xplorer V 08/2015
Gimbal Ver. 50521
Flight Controller Unit: 50913
Camera Ver. UG3300_C_FW_4.9.1_150827_H
App Ver. 2.2.0.0623

invid199
Posts: 1
Joined: Sun May 15, 2016 7:43 pm

Re: Remote Controller and Drone

Post by invid199 » Sun May 15, 2016 7:46 pm

hi, i had have the same issue but after i calibrate my drone controll I could pair with the drone. I hope this is usefull for you guys

harbak62
Posts: 1
Joined: Mon Dec 19, 2016 2:19 pm

Re: Remote Controller and Drone

Post by harbak62 » Mon Dec 19, 2016 2:26 pm

I have had this same issues and found that by calibrating my Remote Control using the Xiro Assistant corrected this issue. I had to go through the help to identify how to correctly setup the Controller but once I did it now corrects the controller every time I make a changes requiring a re-syncing of the system.

brig57
Posts: 3
Joined: Tue Feb 21, 2017 8:19 am

Re: Remote Controller and Drone

Post by brig57 » Sat Feb 25, 2017 7:30 pm

I have the very same problem. Started this morning.
I checked everything with the Xiro Wizard, all good.
Turned everything off and when I tried later
Remote flashes same way, lights on drone are all red.
Best drone I ever bought, had it long enough for a few
test run....
Now Nothing
brig57
Edward Brigman

Dam18
Posts: 1
Joined: Sun Apr 30, 2017 2:44 am

Re: Remote Controller and Drone

Post by Dam18 » Sun Apr 30, 2017 2:48 am

I had the same issue..recalibrate the remote with xiro assistant app on your desktop..then rebind controller with drone...the pin reset button is under the gimbal..go to YouTube to see how u rebind

Post Reply