Xplorer G Live video preview not working

Ask for advice with fixing or repairing or custom modifications here.
Post Reply
radeluca92
Posts: 1
Joined: Thu Feb 09, 2017 4:45 pm

Xplorer G Live video preview not working

Post by radeluca92 » Thu Feb 09, 2017 5:47 pm

Hello, I just recently purchased an Explorer G on amazon. Great value, and it's so much fun to fly. I am having trouble getting one of it's main features to work though.

I have a gopro hero4 black that will not show live video in the Xiro app. The app says the camera is connected but the screen remains black. I understand that i can't start/stop recording with the G model but I believe i am supposed to at least see the live video while flying.

Steps I have taken so far:

Upgrade and downgrade my Gopro software
Tried Android app v2.07 and the older android app
Tried iOS app
Updated Gimbal software via Xiro Assistant
Updated Flight control software via Xiro Assistant
Made sure app and transmitter bind to camera successfully in the app settings
Reset camera/gimbal completely using extensive instructions found on this forum

Everything is working flawlessly. Gimbal goes up and down and stabilizes, I have no issues whatsoever using the drone other than I can't see where my drone is going via the video feed.

I am new to drones so I am not sure if this may be a camera problem or a gimbal problem. I have contacted xiro support on their website and through amazon who i purchased it but have not received a response yet.

anyone have any ideas?

Post Reply