Hello From Central West Queensland, Australia

Use this place to introduce yourselves and general chit chat
Post Reply
Posts: 2
Joined: Mon Jan 09, 2017 10:20 am

Hello From Central West Queensland, Australia

Post by Patandmick » Tue Jan 10, 2017 11:57 am

Hi all, I'm Mick. Bought myself an Xplorer V for my Birthday back in mid December and despite a few hiccups, still think it is absolutely awesome.

Currently having problems after firmware upgrades, which seem to have all installed properly. After the start up sounds the unit fails to do the self check. Instead the power switch on top of the drone just keeps blinking green & none of the nav lights underneath light up at all.

App still lets me see live video, change passwords & settings etc. Range extender shows as paired. Have tried to pair the remote, but drone does not seem to have let me in that far to attempt that.

is there a simple factory reset option so that I may undo all of my upgrades and try again?


Posts: 7
Joined: Sun Apr 09, 2017 10:45 am
Location: Brisbane, Australia

Re: Hello From Central West Queensland, Australia

Post by njmcgregor » Sun Apr 09, 2017 11:46 am

Mick, hello.

I had a similar issue with after the firmware update, I just re-installed all the. All lights were red.

Did the pairing twice and seemed to fix it. (make sure the pin in the back of the drone after removing the gimbal is pushed done hard until you feel like a button pushed in)

I had to reinstall the firmware update as I lost all gimbal control, reinstalled the firmware for the gimbal and fixed it.

Also where in Central Queensland are you?


Post Reply